import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@import \\b.*[\\\"']([^)]*)[\\\"']";
final String string = "@import url(\"fineprint.css\") print;\n"
+ "@import url(\"bluish.css\") projection, tv;\n"
+ "@import 'custom.css';\n"
+ "@import url(\"chrome://communicator/skin/\");\n"
+ "@import \"common.css\" screen, projection;\n"
+ "@import url('landscape.css') screen and (orientation:landscape);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}