re = /^[0-9]{1,2}\.[0-9]{1,2}\.[0-9]{1,2}([0-9]{5,7}[X|B]([0-9]{1,2}))?$/m
str = '1.1.1111111X1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end