package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,2}\.[0-9]{1,2}\.[0-9]{1,2}([0-9]{5,7}[X|B]([0-9]{1,2}))?$`)
var str = `1.1.1111111X1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}