re = /^\d{4}-(((0[13578]|1[02])-(0[1-9]|[12]\d|3[0-1]))|(02-(0[1-9]|[12]\d))|((0[469]|11)-(0[1-9]|[12]\d|30)))$/m
str = '652015-07-017987987
2051-54-45
2222-12-31
2015-07-01
2015-07-32
2015-06-31
2015-02-30
6542015-07-10654654
6542222-12-31654
^[0-9]{4}-(((0[13578]|(10|12))-(0[1-9]|[1-2][0-9]|3[0-1]))|(02-(0[1-9]|[1-2][0-9]))|((0[469]|11)-(0[1-9]|[1-2][0-9]|30)))$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end