import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}-(((0[13578]|1[02])-(0[1-9]|[12]\\d|3[0-1]))|(02-(0[1-9]|[12]\\d))|((0[469]|11)-(0[1-9]|[12]\\d|30)))$";
final String string = "652015-07-017987987\n"
+ "2051-54-45\n"
+ "2222-12-31\n"
+ "2015-07-01\n"
+ "2015-07-32\n"
+ "2015-06-31\n"
+ "2015-02-30\n"
+ "6542015-07-10654654\n"
+ "6542222-12-31654\n\n"
+ "^[0-9]{4}-(((0[13578]|(10|12))-(0[1-9]|[1-2][0-9]|3[0-1]))|(02-(0[1-9]|[1-2][0-9]))|((0[469]|11)-(0[1-9]|[1-2][0-9]|30)))$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}