# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(\d|\+|\(|)
(\d+|xx)
(xx|.)?
(\d+|.)?
(\))?
(\d)?
(\d|.)?
(\))?
.+
"""
test_str = ("9876-5432\n"
"98765-4321\n"
"11 9876-5432\n"
"011 9876-5432\n"
"0xx11 9876-5432\n"
"0xx 11 9876-5432\n"
"+55 11 9876-5432\n"
"+55 11 98765-4321\n"
"+551198765432\n"
"+5511987654321\n"
"(11)9876-5432\n"
"(11) 9876-5432\n"
"(0xx11) 9876-5432\n"
"+55 (11) 98765-4321")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.