using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d|\+|\(|)
(\d+|xx)
(xx|.)?
(\d+|.)?
(\))?
(\d)?
(\d|.)?
(\))?
.+";
string input = @"9876-5432
98765-4321
11 9876-5432
011 9876-5432
0xx11 9876-5432
0xx 11 9876-5432
+55 11 9876-5432
+55 11 98765-4321
+551198765432
+5511987654321
(11)9876-5432
(11) 9876-5432
(0xx11) 9876-5432
+55 (11) 98765-4321";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}