re = /match this (?:match that)/im
str = 'match this match that/// TRC20.sol -- API for the TRC20 token standard
// See <https://github.com/tronprotocol/tips/blob/master/tip-20.md>.
// This file likely does not meet the threshold of originality
// required for copyright to apply. As a result, this is free and
// unencumbered software belonging to the public domain.
pragma solidity >=0.4.25;
contract TRC20Events {
event Approval(address indexed src, address indexed guy, uint wad);
event Transfer(address indexed src, address indexed dst, uint wad);
}
contract TRC20 is TRC20Events {
function totalSupply() public view returns (uint);
function balanceOf(address guy) public view returns (uint);
function allowance(address src, address guy) public view returns (uint);
function approve(address guy, uint wad) public returns (bool);
function transfer(address dst, uint wad) public returns (bool);
function transferFrom(
address src, address dst, uint wad
) public returns (bool);
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end