import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "match this (?:match that)";
final String string = "match this match that/// TRC20.sol -- API for the TRC20 token standard\n\n"
+ "// See <https://github.com/tronprotocol/tips/blob/master/tip-20.md>.\n\n"
+ "// This file likely does not meet the threshold of originality\n\n"
+ "// required for copyright to apply. As a result, this is free and\n\n"
+ "// unencumbered software belonging to the public domain.\n\n"
+ "pragma solidity >=0.4.25;\n\n"
+ "contract TRC20Events {\n\n"
+ " event Approval(address indexed src, address indexed guy, uint wad);\n\n"
+ " event Transfer(address indexed src, address indexed dst, uint wad);\n\n"
+ "}\n\n"
+ "contract TRC20 is TRC20Events {\n\n"
+ " function totalSupply() public view returns (uint);\n\n"
+ " function balanceOf(address guy) public view returns (uint);\n\n"
+ " function allowance(address src, address guy) public view returns (uint);\n\n"
+ " function approve(address guy, uint wad) public returns (bool);\n\n"
+ " function transfer(address dst, uint wad) public returns (bool);\n\n"
+ " function transferFrom(\n\n"
+ " address src, address dst, uint wad\n\n"
+ " ) public returns (bool);\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}