const regex = new RegExp('packages/(?<package>[^/]+)/(?<version>[^/]+)', 'gm')
const str = `packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}