package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)packages/(?<package>[^/]+)/(?<version>[^/]+)`)
var str = `packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}