# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((1000)|([2][5]\d)|(([3456789]\d\d)))(?= {0,}(г|м))|(((?<=\D)[\d])|((0(.|,)[3456789][\d]))|([2][6789]))(?= {0,}(л|к))"
test_str = ("0.26 кг\n"
"251 гр\n\n"
"Баранки Белицкие 400г.РБ\n"
"Белизна Российская Идеал 1000мл РФ\n"
"Вафли с аром.лесного ореха 1кг РФ\n"
"Вафли Фруктоша с корицей 1кг РБ\n"
"Вино Искорка пл,кр, 0,7л РБ\n"
"Вода мин, Минск-4 0,5л РБ\n"
"Жеват резинка Цветной язык 32,3гр РФ\n"
"Жевательная резинка с наполн Арбузики 32,3гр РФ\n"
"Зефир Панский с вар,сгущ, 1кг РБ\n"
"Йогурт для д/п Лесная ягода 2,6%мдж 207гр Беллакт\n"
"Карамель глаз с ликёрной нач Ясный месяц 1кг Украина\n"
"Карамель Дивная Даренка с начин.1кг РФ\n"
"Карамель со вкусом барбариса 1кг РФ\n"
"Каша б/приг Оригинальная 7 злаков 150гр РФ\n"
"Кефир обог.вит.Д3 пленка 1,6% 1л Савушкин РБ\n"
"Колбаса в/к Сервелат с паприкой в/с 390гр Комертекс\n"
"Колбаса вар Мортаделла 1с 1кг Ганна\n"
"Колбаса кровяная Шляхцецкая 1кг.Минск\n"
"Колбаса оригинальная Сервелат новый газ 1кг РБ\n"
"Консерва Треска с рисом и овощами 130гр Беллакт РБ\n"
"Конфета Лещина 1кг. Украина\n"
"Конфеты Cont&blue Клубника 1кг\n"
"Конфеты Ассорти 235гр РФ\n"
"Конфеты Тишка глаз вар сгущ/карам/возд рис (200гр) РФ\n"
"Конфеты Фруктовые забавы теплая вишня 1кг РБ\n"
"Конфеты шоколадные Assorted Chocolates асс 400гр Германия\n"
"Конфеты шоколадные Wamer Hudson ассорти 150гр Германия\n"
"Котлеты овощные заморож 360гр РБ\n"
"Кофе Якобз Монарх раств сублим 47,5гр РФ\n"
"Крекер Чипо с сыром 1кг. РФ\n"
"Маска Acme-Color д/всех типов волос 500мл Украина\n"
"Мороженое Птичье молоко Пломбир с аром сливочн крема 80гр РБ\n"
"не выбирать Ноги свиные 1кг.РБ\n"
"не выбирать Продукт из свин солен руб Акварель 1кг. РБ\n"
"не выбирать Продукт из свин.сол.руб. Акварель 1кг.РБ\n"
"Нектар Добрый абрикос 1л. РБ\n"
"Нектар Мультифруктовый 0,95л Оазис-Групп\n"
"Ноги свиные 1кг.РБ*\n"
"Ножка цыплёнка в панировке п/ф рубленый 1кг РФ\n"
"Ножка цыпленка в панировке рубленый (1кг) Россия\n"
"Носки женские 14С1300 р23-25 Брест\n"
"Овощи Весенние (зам) 400гр Санта РБ\n"
"ок томатный с мякотью и солью 3л Ляховичи РБ\n"
"Окорочок цыплёнка в панировке 1кн РФ\n"
"Окорочок цыплёнка в панировке п/ф рубленый 1кг РФ\n"
"П/Ф рубл Фарш Деревенский (1кг) БМК\n"
"П/Ф Сердце говяжье Селянское (зам) 1кг КМК\n"
"П/Ф Торетте с мясом и сыром из мяса/пт 430гр БМК\n"
"П/Ф Фарш рубл Деревенский (зам) соленый 1кг БМК\n"
"Палочки Stickletti original солёные 125гр Венгрия\n"
"Паштет Лакомка мясной запеч, терм,обр, 1кг РБ Брест\n"
"Пельмени Сочные вес.1кг. РБ\n"
"Перец фаршированный 1кг.РФ\n"
"Печенье LUKAS PALMIERS слоёное с изюмом 230гр Украина\n"
"Печенье сах Две стихии глаз 1кг Украина\n"
"Печенье Смуглянка 1кг Украина\n"
"Печенье Чайный Слодыч 1кг РБ\n"
"Пицца Калифорния мясное ассорти 330гр ПровитБел\n"
"Приправа универсальная 30г РБ\n"
"Прод плав с сыром колбасн копчен Буренкин 40% 1кг. РФ\n"
"Продукт из свинины Акварель руб.1кг.РБбрак\n"
"Пудинг Нежный ванильный 2,4% 115г.РФ\n"
"Салака копчено-провесная 250гр Санта\n"
"Сардина атл с доб масла 200гр Рыбарь РФ\n"
"Сардина атлант с добавл масла 200гр Рыбарь Россия\n"
"Сельдб кусок г/к в масле с ароматом дыма 500/350гр РБ\n"
"Сельдь атлант. с доб.масла ж/б 200гр РФ\n"
"Сельдь т/о крупн жирн сорт1 1*10 Россия\n"
"Семечки жар.без соли 190гр.РБ\n"
"Сервелат Барбадос фирменный в/к 1кгРБ Имперфуд\n"
"Смесь сухая NAN г/а Optipro-НА с 6-ти мес. Германия\n"
"Сметана 20%мдж 400гр Бабушкина крынка\n"
"Сметана 22% мдж 200гр Бабушкина крынка\n"
"Сметана 22%мдж 9плёнка) 400гр ММК\n"
"Сметана Свежие новости 22% 200гр (стакан) РБ\n"
"Сок Добрый абрикос2л. РБ\n"
"Сок Добрый ананас 2л. РБ\n"
"Сок Добрый мультифруктовый 2л. РФ\n"
"Сок Добрый тамат 2л. РБ\n"
"Сок Добрый томатный 1л. РБ\n"
"Сок Добрый яблоко 2л. РБ\n"
"Сок Добрый яблочный 1л. РБ\n"
"Сок Экзотик Томатный 1л. РБ\n"
"Соломка сладкая Pif-Paf 40гр РБ\n"
"Ср-во инсектицидное Дихлофос Варан А от насек,300мл Польша\n"
"Ср-во отбел, Бос-плюс maximum 600г РФ\n"
"Средство д/посуды Fairy Апельсин и лимонник 500мл РФ\n"
"Сухари с ванилином 1кг Минскхлебпром Беларусь\n"
"Сухарики Хрусteam со вкусом Баварские колбаски 90гр РФ\n"
"Сыр п/твёрд Сулугуни Granabella 45% в/у 240гр РБ\n"
"Сыр Сулугуни GRANABELLA 45%мдж 240гр Беларусь\n"
"Творог Деревенский биф/бак 2% 1кг. ММК\n"
"Творог зерн.Кали Ласка сливки 4% 140гр. ММК**************\n"
"Творог зерн.сливки 4% 230гр. ММК\n"
"торт Баловень 0,9 РБ Осиповичи\n"
"Торт Дарина 0,9 РБ Осиповичи\n"
"Фрутелла Ассорти клуб-апельс-лимон 41гр РФ\n"
"Халва Дружковская подсолн ванильная 80гр Украина\n"
"Хлеб Сяброуски 225г.Хлебпром\n"
"Чай Curtis Banana Flambe 1,8х20гр РФ\n"
"Чай зел Lipton Earl Grey 25*2 РФ\n"
"Чай ОК чёрный с аром земляники 20х1,5гр б/я РФ\n"
"Чай Хейлис чёрный, крупный лист 100гр РФ\n"
"Чай Хэйлис 1,5гр креп 100пак РФ\n"
"Чайм зел Липтон Грин 1,7*25пак РФ\n"
"Чипсы Онега вк, сметаны и лука 300гр РБ\n"
"Шоколад молочный с арахисом 90гр РФ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.