#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((1000)|([2][5]\d)|(([3456789]\d\d)))(?= {0,}(г|м))|(((?<=\D)[\d])|((0(.|,)[3456789][\d]))|([2][6789]))(?= {0,}(л|к))"
Local $sString = "0.26 кг" & @CRLF & _
"251 гр" & @CRLF & _
"" & @CRLF & _
"Баранки Белицкие 400г.РБ" & @CRLF & _
"Белизна Российская Идеал 1000мл РФ" & @CRLF & _
"Вафли с аром.лесного ореха 1кг РФ" & @CRLF & _
"Вафли Фруктоша с корицей 1кг РБ" & @CRLF & _
"Вино Искорка пл,кр, 0,7л РБ" & @CRLF & _
"Вода мин, Минск-4 0,5л РБ" & @CRLF & _
"Жеват резинка Цветной язык 32,3гр РФ" & @CRLF & _
"Жевательная резинка с наполн Арбузики 32,3гр РФ" & @CRLF & _
"Зефир Панский с вар,сгущ, 1кг РБ" & @CRLF & _
"Йогурт для д/п Лесная ягода 2,6%мдж 207гр Беллакт" & @CRLF & _
"Карамель глаз с ликёрной нач Ясный месяц 1кг Украина" & @CRLF & _
"Карамель Дивная Даренка с начин.1кг РФ" & @CRLF & _
"Карамель со вкусом барбариса 1кг РФ" & @CRLF & _
"Каша б/приг Оригинальная 7 злаков 150гр РФ" & @CRLF & _
"Кефир обог.вит.Д3 пленка 1,6% 1л Савушкин РБ" & @CRLF & _
"Колбаса в/к Сервелат с паприкой в/с 390гр Комертекс" & @CRLF & _
"Колбаса вар Мортаделла 1с 1кг Ганна" & @CRLF & _
"Колбаса кровяная Шляхцецкая 1кг.Минск" & @CRLF & _
"Колбаса оригинальная Сервелат новый газ 1кг РБ" & @CRLF & _
"Консерва Треска с рисом и овощами 130гр Беллакт РБ" & @CRLF & _
"Конфета Лещина 1кг. Украина" & @CRLF & _
"Конфеты Cont&blue Клубника 1кг" & @CRLF & _
"Конфеты Ассорти 235гр РФ" & @CRLF & _
"Конфеты Тишка глаз вар сгущ/карам/возд рис (200гр) РФ" & @CRLF & _
"Конфеты Фруктовые забавы теплая вишня 1кг РБ" & @CRLF & _
"Конфеты шоколадные Assorted Chocolates асс 400гр Германия" & @CRLF & _
"Конфеты шоколадные Wamer Hudson ассорти 150гр Германия" & @CRLF & _
"Котлеты овощные заморож 360гр РБ" & @CRLF & _
"Кофе Якобз Монарх раств сублим 47,5гр РФ" & @CRLF & _
"Крекер Чипо с сыром 1кг. РФ" & @CRLF & _
"Маска Acme-Color д/всех типов волос 500мл Украина" & @CRLF & _
"Мороженое Птичье молоко Пломбир с аром сливочн крема 80гр РБ" & @CRLF & _
"не выбирать Ноги свиные 1кг.РБ" & @CRLF & _
"не выбирать Продукт из свин солен руб Акварель 1кг. РБ" & @CRLF & _
"не выбирать Продукт из свин.сол.руб. Акварель 1кг.РБ" & @CRLF & _
"Нектар Добрый абрикос 1л. РБ" & @CRLF & _
"Нектар Мультифруктовый 0,95л Оазис-Групп" & @CRLF & _
"Ноги свиные 1кг.РБ*" & @CRLF & _
"Ножка цыплёнка в панировке п/ф рубленый 1кг РФ" & @CRLF & _
"Ножка цыпленка в панировке рубленый (1кг) Россия" & @CRLF & _
"Носки женские 14С1300 р23-25 Брест" & @CRLF & _
"Овощи Весенние (зам) 400гр Санта РБ" & @CRLF & _
"ок томатный с мякотью и солью 3л Ляховичи РБ" & @CRLF & _
"Окорочок цыплёнка в панировке 1кн РФ" & @CRLF & _
"Окорочок цыплёнка в панировке п/ф рубленый 1кг РФ" & @CRLF & _
"П/Ф рубл Фарш Деревенский (1кг) БМК" & @CRLF & _
"П/Ф Сердце говяжье Селянское (зам) 1кг КМК" & @CRLF & _
"П/Ф Торетте с мясом и сыром из мяса/пт 430гр БМК" & @CRLF & _
"П/Ф Фарш рубл Деревенский (зам) соленый 1кг БМК" & @CRLF & _
"Палочки Stickletti original солёные 125гр Венгрия" & @CRLF & _
"Паштет Лакомка мясной запеч, терм,обр, 1кг РБ Брест" & @CRLF & _
"Пельмени Сочные вес.1кг. РБ" & @CRLF & _
"Перец фаршированный 1кг.РФ" & @CRLF & _
"Печенье LUKAS PALMIERS слоёное с изюмом 230гр Украина" & @CRLF & _
"Печенье сах Две стихии глаз 1кг Украина" & @CRLF & _
"Печенье Смуглянка 1кг Украина" & @CRLF & _
"Печенье Чайный Слодыч 1кг РБ" & @CRLF & _
"Пицца Калифорния мясное ассорти 330гр ПровитБел" & @CRLF & _
"Приправа универсальная 30г РБ" & @CRLF & _
"Прод плав с сыром колбасн копчен Буренкин 40% 1кг. РФ" & @CRLF & _
"Продукт из свинины Акварель руб.1кг.РБбрак" & @CRLF & _
"Пудинг Нежный ванильный 2,4% 115г.РФ" & @CRLF & _
"Салака копчено-провесная 250гр Санта" & @CRLF & _
"Сардина атл с доб масла 200гр Рыбарь РФ" & @CRLF & _
"Сардина атлант с добавл масла 200гр Рыбарь Россия" & @CRLF & _
"Сельдб кусок г/к в масле с ароматом дыма 500/350гр РБ" & @CRLF & _
"Сельдь атлант. с доб.масла ж/б 200гр РФ" & @CRLF & _
"Сельдь т/о крупн жирн сорт1 1*10 Россия" & @CRLF & _
"Семечки жар.без соли 190гр.РБ" & @CRLF & _
"Сервелат Барбадос фирменный в/к 1кгРБ Имперфуд" & @CRLF & _
"Смесь сухая NAN г/а Optipro-НА с 6-ти мес. Германия" & @CRLF & _
"Сметана 20%мдж 400гр Бабушкина крынка" & @CRLF & _
"Сметана 22% мдж 200гр Бабушкина крынка" & @CRLF & _
"Сметана 22%мдж 9плёнка) 400гр ММК" & @CRLF & _
"Сметана Свежие новости 22% 200гр (стакан) РБ" & @CRLF & _
"Сок Добрый абрикос2л. РБ" & @CRLF & _
"Сок Добрый ананас 2л. РБ" & @CRLF & _
"Сок Добрый мультифруктовый 2л. РФ" & @CRLF & _
"Сок Добрый тамат 2л. РБ" & @CRLF & _
"Сок Добрый томатный 1л. РБ" & @CRLF & _
"Сок Добрый яблоко 2л. РБ" & @CRLF & _
"Сок Добрый яблочный 1л. РБ" & @CRLF & _
"Сок Экзотик Томатный 1л. РБ" & @CRLF & _
"Соломка сладкая Pif-Paf 40гр РБ" & @CRLF & _
"Ср-во инсектицидное Дихлофос Варан А от насек,300мл Польша" & @CRLF & _
"Ср-во отбел, Бос-плюс maximum 600г РФ" & @CRLF & _
"Средство д/посуды Fairy Апельсин и лимонник 500мл РФ" & @CRLF & _
"Сухари с ванилином 1кг Минскхлебпром Беларусь" & @CRLF & _
"Сухарики Хрусteam со вкусом Баварские колбаски 90гр РФ" & @CRLF & _
"Сыр п/твёрд Сулугуни Granabella 45% в/у 240гр РБ" & @CRLF & _
"Сыр Сулугуни GRANABELLA 45%мдж 240гр Беларусь" & @CRLF & _
"Творог Деревенский биф/бак 2% 1кг. ММК" & @CRLF & _
"Творог зерн.Кали Ласка сливки 4% 140гр. ММК**************" & @CRLF & _
"Творог зерн.сливки 4% 230гр. ММК" & @CRLF & _
"торт Баловень 0,9 РБ Осиповичи" & @CRLF & _
"Торт Дарина 0,9 РБ Осиповичи" & @CRLF & _
"Фрутелла Ассорти клуб-апельс-лимон 41гр РФ" & @CRLF & _
"Халва Дружковская подсолн ванильная 80гр Украина" & @CRLF & _
"Хлеб Сяброуски 225г.Хлебпром" & @CRLF & _
"Чай Curtis Banana Flambe 1,8х20гр РФ" & @CRLF & _
"Чай зел Lipton Earl Grey 25*2 РФ" & @CRLF & _
"Чай ОК чёрный с аром земляники 20х1,5гр б/я РФ" & @CRLF & _
"Чай Хейлис чёрный, крупный лист 100гр РФ" & @CRLF & _
"Чай Хэйлис 1,5гр креп 100пак РФ" & @CRLF & _
"Чайм зел Липтон Грин 1,7*25пак РФ" & @CRLF & _
"Чипсы Онега вк, сметаны и лука 300гр РБ" & @CRLF & _
"Шоколад молочный с арахисом 90гр РФ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")