$re = '/\b[\w.!#$%&’*+\/=?^`{|}~-]+@[\w-]+(?:\.[\w-]+)*\b/m';
$str = 'Matches an email address like john.doe@my-domain.com inside text
valid-email@email.com
not!valid@#email.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);