const regex = /\b[\w.!#$%&’*+\/=?^`{|}~-]+@[\w-]+(?:\.[\w-]+)*\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[\\w.!#$%&’*+\\\/=?^`{|}~-]+@[\\w-]+(?:\\.[\\w-]+)*\\b', 'mg')
const str = `Matches an email address like john.doe@my-domain.com inside text
valid-email@email.com
not!valid@#email.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}