const regex = /(\b\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\d+)?(\.?\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\d+?)?|S))(-?\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\d+)?))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\\d+)?(\\.?\\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\\d+?)?|S))(-?\\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\\d+)?))', 'gm')
const str = `62877K`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}