using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\d{5})((##DEU-Akten|[PZ] ?DEU)|(##Schutzerstreckungen|W ?WOS)|(##Widerspruch|[BRK] ?([A-Z]{2}|[MZ][123]|R1|T[12])([-_]?([A-Z]{2}|[MZ][123]|R1|T[12]))?(-?\d+)?(\.?\d+)?)|(##mitLand|([PZGDWSEL]|[NVYTXCUAK]) ?((((HK-?CN)|(([A-Z]{2}|[MZ][123]|R1|T[12])(-?EP|-?EM|-?AP|-?OA)?))(-?WO|-?W\d+?)?|S))(-?\d+)?)|((##ohneLand|[NVYTXCUAK])(-?\d+)?))";
string input = @"62877K";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}