import Foundation
let pattern = #"service\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\-v(?P<versionMajor>[0-9]+)\.(?P<versionMinor>[0-9]+)\.(?P<versionPatch>[0-9]+)(?:\-(?P<versionType>alpha|beta|rc)(?:\.(?P<versionTypeNumber>[0-9]+)))?\.(?P<fileExt>gtw)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
service-bad-v1.0.0-ddd.1.gtw
service-bad-v.0.0.gtw
service-bad-v1..0.gtw
service-bad-1.0.0.gtw
service-bad-cool--v1.0.0-alpha.1.gtw
service--bad-cool-v1.0.0-alpha.1.gtw
service-user-v1.0.0
service-user-v1.0.0-alpha.1
service-channel-cool-v1.0.0-alpha.1
service-user-v1.0.0.gtw
service-user-v1.0.0-alpha.1.gtw
service-channel-cool-v1.0.0-alpha.1.gtw
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)