package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`service\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\-v(?P<versionMajor>[0-9]+)\.(?P<versionMinor>[0-9]+)\.(?P<versionPatch>[0-9]+)(?:\-(?P<versionType>alpha|beta|rc)(?:\.(?P<versionTypeNumber>[0-9]+)))?\.(?P<fileExt>gtw)`)
var str = `service-bad-v1.0.0-ddd.1.gtw
service-bad-v.0.0.gtw
service-bad-v1..0.gtw
service-bad-1.0.0.gtw
service-bad-cool--v1.0.0-alpha.1.gtw
service--bad-cool-v1.0.0-alpha.1.gtw
service-user-v1.0.0
service-user-v1.0.0-alpha.1
service-channel-cool-v1.0.0-alpha.1
service-user-v1.0.0.gtw
service-user-v1.0.0-alpha.1.gtw
service-channel-cool-v1.0.0-alpha.1.gtw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}