const regex = /^((?:https?|ftp|smtp):\/\/)?((?:[a-z0-9]+\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\d|1?\d{2}|\d)\.){3}(?:25[0-5]|2[0-4]\d|1?\d{2}|\d))(:\d+)?(\/.+\/?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:https?|ftp|smtp):\\\/\\\/)?((?:[a-z0-9]+\\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\\d|1?\\d{2}|\\d)\\.){3}(?:25[0-5]|2[0-4]\\d|1?\\d{2}|\\d))(:\\d+)?(\\\/.+\\\/?)*$', 'gm')
const str = `https://www.reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://www.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://old.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.0.0.1:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://localhost:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://new.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://420.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
ftp://ftp.mitsu.xd:6969/secret-linux-isos
smtp://69.420.com/does-smtp-even-supports-paths?idk=pls%20help
https://pbs.twimg.com/media/FXiW8wAXwAAqKe3.jpg?name=orig
# Don't match these:
https://foo#bad.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://.../r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://1024.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://360.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
https://127.w.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}