import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:https?|ftp|smtp):\\/\\/)?((?:[a-z0-9]+\\.)*[a-z]+|(?:(?:25[0-5]|2[0-4]\\d|1?\\d{2}|\\d)\\.){3}(?:25[0-5]|2[0-4]\\d|1?\\d{2}|\\d))(:\\d+)?(\\/.+\\/?)*$";
final String string = "https://www.reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://www.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://old.reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://reddit.co.jp/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://reddit.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://localhost/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://127.0.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://127.0.0.1:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://localhost:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://new.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://420.reddit.com:3000/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "ftp://ftp.mitsu.xd:6969/secret-linux-isos\n"
+ "smtp://69.420.com/does-smtp-even-supports-paths?idk=pls%20help\n"
+ "https://pbs.twimg.com/media/FXiW8wAXwAAqKe3.jpg?name=orig\n\n"
+ "# Don't match these:\n"
+ "https://foo#bad.com/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://.../r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://1024.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://360.0.0.7/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n"
+ "https://127.w.0.1/r/ProgrammerHumor/comments/vxhbku/a_regex_god/\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}