$re = '/(\d+)-(\w{3}?)-(\d{6}?)-(\w+?)-/m';
$str = '80-pcc-000670-WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads/WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads-1551388618-res.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);