const regex = /(\d+)-(\w{3}?)-(\d{6}?)-(\w+?)-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)-(\\w{3}?)-(\\d{6}?)-(\\w+?)-', 'gm')
const str = `80-pcc-000670-WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads/WEBAPP-vdb-1vmdk-80ws-64k-100random-0rdpct-4threads-1551388618-res.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}