re = /(([\w\s\d]+\s)(is the|is a|are the|are a|was)\s([\w\d\s\[\]\)\(,']+))/
str = 'Hendrik Weber (born 1975), better known as Pantha du Prince, Panthel and Glühen 4 is a German producer, composer and conceptual artist for Electro, Techno, House, Minimal and Noise affiliated with Hamburg\'s Dial music label[1][2] and British label Rough Trade.[3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end