package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([\w\s\d]+\s)(is the|is a|are the|are a|was)\s([\w\d\s\[\]\)\(,']+))`)
var str = `Hendrik Weber (born 1975), better known as Pantha du Prince, Panthel and Glühen 4 is a German producer, composer and conceptual artist for Electro, Techno, House, Minimal and Noise affiliated with Hamburg's Dial music label[1][2] and British label Rough Trade.[3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}