re = /(^https?:\/\/)?(\w+)?\.?(reddit\.com\/|redd\.it\/)(r\/\w+\/)?/m
str = 'https://redd.it/
https://reddit.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end