package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^https?:\/\/)?(\w+)?\.?(reddit\.com\/|redd\.it\/)(r\/\w+\/)?`)
var str = `https://redd.it/
https://reddit.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}