$re = '/\b\d{1}\s\d{3}(?!\s\d{3})\b/m';
$str = '1234
1 234
1 234 456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);