const regex = /\b\d{1}\s\d{3}(?!\s\d{3})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{1}\\s\\d{3}(?!\\s\\d{3})\\b', 'gm')
const str = `1234
1 234
1 234 456
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}