$re = '/[a-f0-9]{4}-[a-f0-9]{6}-[a-f0-9]{12}-[a-f0-9]{5}-[a-f0-9]{9}/';
$str = '4be3-eda97a-0d7faeab05a0-89403-ad4751c49';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);