using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-f0-9]{4}-[a-f0-9]{6}-[a-f0-9]{12}-[a-f0-9]{5}-[a-f0-9]{9}";
string input = @"4be3-eda97a-0d7faeab05a0-89403-ad4751c49";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}