# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div[^<>]*>([\s\S]*?)<\/div>"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\" standalone=\"no\"?>\n"
"<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.1//EN\"\n"
" \"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd\">\n\n"
"<html xmlns=\"http://www.w3.org/1999/xhtml\">\n"
"<head>\n"
" <title>A Dança dos Dragões - As Crônicas de Gelo e Fogo</title>\n"
" <link href=\"../Styles/9788580445763_a_danca_dos_dragoes.css\" rel=\"stylesheet\" type=\"text/css\" />\n"
"</head>\n\n"
"<body id=\"x9788580445763_a_danca_dos_dragoes\" xml:lang=\"pt-PT\">\n"
" <div class=\"Basic-Text-Frame\">\n"
" <p class=\"TOC\"><span class=\"Bold\"> </span></p>\n\n"
" <p class=\"after-10\"><span class=\"Bold\"> </span></p>\n\n"
" <p class=\"titulo-ficha-tecnica-before10\" id=\"toc_marker-2\"><span class=\"Bold\">Ficha Técnica</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Copyright © George R. R. Martin</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Todos os direitos reservados.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Versão brasileira © 2012 Texto Editores Ltda.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Título original: A Dance with Dragons<br />\n"
" <br /></span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Diretor editorial: Pascoal Soto</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Produtora editorial: Sonnini Ruiz</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Assistente editorial: Carolina Pereira da Rocha<br />\n"
" <br /></span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Coordenação editorial: Estúdio Sabiá</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Preparação de texto: Rosane Albert</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Revisão: Leandro Morita, Valéria Sanalios, Bruno SR</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Ilustração da capa: Marc Simonetti</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Capa: Scintilla Lima</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\"><br />\n"
" <br />\n"
" Dados Internacionais de Catalogação na Publicação (cip)</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">(Câmara Brasileira do Livro, SP, Brasil)<br />\n"
" <br />\n"
" <br />\n"
" Martin, George R. R.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">A dança dos dragões / George R. R. Martin ;</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">tradução Marcia Blasques. − São Paulo : Leya,</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">2012. – (Coleção as crônicas de gelo e fogo ; 5)<br />\n"
" <br />\n"
" Título original: A dance with dragons.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">ISBN 9788580445763<br />\n"
" <br /></span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">1. Ficção fantástica norte-americana. I. Título. II. Série.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">12-08553 CDD-813.5</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\"><br />\n"
" <br />\n"
" Índices para catálago sistemático:</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">1. Ficção : Literatura norte-americana 813.5<br />\n"
" <br />\n"
" <br />\n"
" Texto Editores Ltda.</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">[Uma editora do grupo LeYa]</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">Rua Desembagador Paulo Passaláqua, 86</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><span class=\"Regular\">01248-010 – Pacaembu – São Paulo – SP</span></p>\n\n"
" <p class=\"texto-ficha-tecnica\"><a href=\"http://www.leya.com\"><span class=\"Regular\">www.leya.com</span></a></p>\n"
" </div>\n"
"</body>\n"
"</html>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.