#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div[^<>]*>([\s\S]*?)<\/div>"
Local $sString = "<?xml version="1.0" encoding="utf-8" standalone="no"?>" & @CRLF & _
"<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"" & @CRLF & _
" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">" & @CRLF & _
"" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head>" & @CRLF & _
" <title>A Dança dos Dragões - As Crônicas de Gelo e Fogo</title>" & @CRLF & _
" <link href="../Styles/9788580445763_a_danca_dos_dragoes.css" rel="stylesheet" type="text/css" />" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body id="x9788580445763_a_danca_dos_dragoes" xml:lang="pt-PT">" & @CRLF & _
" <div class="Basic-Text-Frame">" & @CRLF & _
" <p class="TOC"><span class="Bold"> </span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="after-10"><span class="Bold"> </span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="titulo-ficha-tecnica-before10" id="toc_marker-2"><span class="Bold">Ficha Técnica</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Copyright © George R. R. Martin</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Todos os direitos reservados.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Versão brasileira © 2012 Texto Editores Ltda.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Título original: A Dance with Dragons<br />" & @CRLF & _
" <br /></span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Diretor editorial: Pascoal Soto</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Produtora editorial: Sonnini Ruiz</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Assistente editorial: Carolina Pereira da Rocha<br />" & @CRLF & _
" <br /></span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Coordenação editorial: Estúdio Sabiá</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Preparação de texto: Rosane Albert</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Revisão: Leandro Morita, Valéria Sanalios, Bruno SR</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Ilustração da capa: Marc Simonetti</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Capa: Scintilla Lima</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular"><br />" & @CRLF & _
" <br />" & @CRLF & _
" Dados Internacionais de Catalogação na Publicação (cip)</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">(Câmara Brasileira do Livro, SP, Brasil)<br />" & @CRLF & _
" <br />" & @CRLF & _
" <br />" & @CRLF & _
" Martin, George R. R.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">A dança dos dragões / George R. R. Martin ;</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">tradução Marcia Blasques. − São Paulo : Leya,</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">2012. – (Coleção as crônicas de gelo e fogo ; 5)<br />" & @CRLF & _
" <br />" & @CRLF & _
" Título original: A dance with dragons.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">ISBN 9788580445763<br />" & @CRLF & _
" <br /></span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">1. Ficção fantástica norte-americana. I. Título. II. Série.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">12-08553 CDD-813.5</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular"><br />" & @CRLF & _
" <br />" & @CRLF & _
" Índices para catálago sistemático:</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">1. Ficção : Literatura norte-americana 813.5<br />" & @CRLF & _
" <br />" & @CRLF & _
" <br />" & @CRLF & _
" Texto Editores Ltda.</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">[Uma editora do grupo LeYa]</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">Rua Desembagador Paulo Passaláqua, 86</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><span class="Regular">01248-010 – Pacaembu – São Paulo – SP</span></p>" & @CRLF & _
"" & @CRLF & _
" <p class="texto-ficha-tecnica"><a href="http://www.leya.com"><span class="Regular">www.leya.com</span></a></p>" & @CRLF & _
" </div>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")