using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""http.*soundcloud.com.*sets\/(.*).*<\/a>";
string input = @"the following URL will be found in a <A>:<br>
<em><a href=""https://www.youtube.com/watch?t=61&v=JozAmXo2bDE"" rel=""nofollow"">https://www.youtube.com/watch?t=61&v=JozAmXo2bDE</a>
<br>
<a href=""https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap"" rel=""nofollow"">https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap</a>
<a href=""https://www.youtube.com/watch?v=VH2QAMMSL40"" rel=""nofollow"">https://www.youtube.com/watch?v=VH2QAMMSL40</a>
<br>
<a href=""http://www.youtube.com/embed/NLqAF9hrVbY"" rel=""nofollow"">http://www.youtube.com/embed/NLqAF9hrVbY</a>
<br>
<a href=""http://youtu.be/NLqAF9hrVbY"" rel=""nofollow"">http://youtu.be/NLqAF9hrVbY</a>
</em><br>
<a href=""http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM"" rel=""nofollow"">http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM</a>
</p>
<a href=""/uploads/files/1438381231924-humanistische-friedenspartei.mp3"">Humanistische - Friedenspartei.mp3</a>
<p>nice... <a href=""/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav"">DRUMLOOP053_AMBNT_160_X_SC5.wav</a></p>
<a href=""/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav"">DRUMLOOP053_AMBNT_160_X_SC5.wav</a>
<p>infos:<br>
<a href=""https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js"" rel=""nofollow"">https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js</a></p>
<p><a href=""https://github.com/ogerly/nodebb-plugin-youtube-lite"" rel=""nofollow"">https://github.com/ogerly/nodebb-plugin-youtube-lite</a></p>
</div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}