#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a href="http.*soundcloud.com.*sets\/(.*).*<\/a>"
Local $sString = "the following URL will be found in a <A>:<br>" & @CRLF & _
"<em><a href="https://www.youtube.com/watch?t=61&v=JozAmXo2bDE" rel="nofollow">https://www.youtube.com/watch?t=61&v=JozAmXo2bDE</a>" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"<a href="https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap" rel="nofollow">https://soundcloud.com/buzzdeny/sets/deutsch-er-hiphop-rap</a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<a href="https://www.youtube.com/watch?v=VH2QAMMSL40" rel="nofollow">https://www.youtube.com/watch?v=VH2QAMMSL40</a>" & @CRLF & _
"<br>" & @CRLF & _
"<a href="http://www.youtube.com/embed/NLqAF9hrVbY" rel="nofollow">http://www.youtube.com/embed/NLqAF9hrVbY</a>" & @CRLF & _
"<br>" & @CRLF & _
"<a href="http://youtu.be/NLqAF9hrVbY" rel="nofollow">http://youtu.be/NLqAF9hrVbY</a>" & @CRLF & _
"</em><br>" & @CRLF & _
"<a href="http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM" rel="nofollow">http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/FJUvudQsKCM</a>" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<a href="/uploads/files/1438381231924-humanistische-friedenspartei.mp3">Humanistische - Friedenspartei.mp3</a>" & @CRLF & _
"" & @CRLF & _
"<p>nice... <a href="/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav">DRUMLOOP053_AMBNT_160_X_SC5.wav</a></p>" & @CRLF & _
"" & @CRLF & _
"<a href="/uploads/files/1438418374790-drumloop053_ambnt_160_x_sc5.wav">DRUMLOOP053_AMBNT_160_X_SC5.wav</a>" & @CRLF & _
"" & @CRLF & _
"<p>infos:<br>" & @CRLF & _
"<a href="https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js" rel="nofollow">https://github.com/ogerly/nodebb-plugin-youtube-lite/blob/master/library.js</a></p>" & @CRLF & _
"<p><a href="https://github.com/ogerly/nodebb-plugin-youtube-lite" rel="nofollow">https://github.com/ogerly/nodebb-plugin-youtube-lite</a></p>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")