re = /^http(s?)\:\/\/[0-9a-zA-Z]([-.\w]*[0-9a-zA-Z])*(:(0-9)*)*(\/?)([a-zA-Z0-9\-\.\?\,\'\/\\\+&%\$#_]*)?(.pdf)$/
str = 'http://regex101.com/javascript/dfdf/fgfg.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end