const regex = /^http(s?)\:\/\/[0-9a-zA-Z]([-.\w]*[0-9a-zA-Z])*(:(0-9)*)*(\/?)([a-zA-Z0-9\-\.\?\,\'\/\\\+&%\$#_]*)?(.pdf)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http(s?)\\:\\\/\\\/[0-9a-zA-Z]([-.\\w]*[0-9a-zA-Z])*(:(0-9)*)*(\\\/?)([a-zA-Z0-9\\-\\.\\?\\,\\\'\\\/\\\\\\+&%\\$#_]*)?(.pdf)$', '')
const str = `http://regex101.com/javascript/dfdf/fgfg.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}