$re = '/^[a-zA-Z0-9_]{2,16}$/m';
$str = 'Steve
Notch
H3robr1ne
Hero-brine
Lie$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);