package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_]{2,16}$`)
var str = `Steve
Notch
H3robr1ne
Hero-brine
Lie$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}