use strict;
my $str = '<div class="pagination" data-source="jsonfields"><!-- Top bar content goes here --><div class="control"><label class="btn-process jsNewItem" data-html="NewItem" data-action="createitem"><span class="navlink-icon"><i class="bx bx-list-plus"></i></span></label><label class="btn-process jsPageItem active pagelink" data-html="PageItem" data-index="1" data-action="navipage"><span class="navlink-text ">1</span><!-- <span class=""></span> --><!-- <input type="hidden" class="text-input " data-parent="" name="" data-suffix="" value=""> --></label><label class="btn-process jsPageItem false pagelink" data-html="PageItem" data-index="2" data-action="navipage"><span class="navlink-text ">2</span><!-- <span class=""></span> --><!-- <input type="hidden" class="text-input " data-parent="" name="" data-suffix="" value=""> --></label></div><div class="parameters"><label class="btn-process checkbox jsAutoItem pagelink" data-action="autorefresh"><input type="checkbox" class="text-input jsAutoRefresh" data-parent="{$CLASSPARENT_FIELDS}" name="autorefresh" {$AUTOREFRESH_FIELD}> Autorefresh</label><label class="btn-process jsRefreshPage pagelink" data-action="refreshpage"><span class="navlink-icon"><i class="bx bx-refresh"></i></span></label></div></div>
<div class="pagination" data-source="jsonfields"><!-- Top bar content goes here --><div class="control"><label class="btn-process jsNewItem" data-html="NewItem" data-action="createitem"><span class="navlink-icon"><i class="bx bx-list-plus"></i></span></label><label class="btn-process jsPageItem active pagelink" data-html="PageItem" data-index="1" data-action="navipage"><span class="navlink-text ">1</span><!-- <span class=""></span> --><!-- <input type="hidden" class="text-input " data-parent="" name="" data-suffix="" value=""> --></label><label class="btn-process jsPageItem false pagelink" data-html="PageItem" data-index="2" data-action="navipage"><span class="navlink-text ">2</span><!-- <span class=""></span> --><!-- <input type="hidden" class="text-input " data-parent="" name="" data-suffix="" value=""> --></label></div><div class="parameters"><label class="btn-process checkbox jsAutoItem pagelink" data-action="autorefresh"><input type="checkbox" class="text-input jsAutoRefresh" data-parent="{$CLASSPARENT_FIELDS}" name="autorefresh" {$AUTOREFRESH_FIELD}> Autorefresh</label><label class="btn-process jsRefreshPage pagelink" data-action="refreshpage"><span class="navlink-icon"><i class="bx bx-refresh"></i></span></label></div></div>';
my $regex = qr/<label\b.*?(data-html="NewItem").*?>.*?<\/label>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}