import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<label\\b.*?(data-html=\"NewItem\").*?>.*?<\\/label>";
final String string = "<div class=\"pagination\" data-source=\"jsonfields\"><!-- Top bar content goes here --><div class=\"control\"><label class=\"btn-process jsNewItem\" data-html=\"NewItem\" data-action=\"createitem\"><span class=\"navlink-icon\"><i class=\"bx bx-list-plus\"></i></span></label><label class=\"btn-process jsPageItem active pagelink\" data-html=\"PageItem\" data-index=\"1\" data-action=\"navipage\"><span class=\"navlink-text \">1</span><!-- <span class=\"\"></span> --><!-- <input type=\"hidden\" class=\"text-input \" data-parent=\"\" name=\"\" data-suffix=\"\" value=\"\"> --></label><label class=\"btn-process jsPageItem false pagelink\" data-html=\"PageItem\" data-index=\"2\" data-action=\"navipage\"><span class=\"navlink-text \">2</span><!-- <span class=\"\"></span> --><!-- <input type=\"hidden\" class=\"text-input \" data-parent=\"\" name=\"\" data-suffix=\"\" value=\"\"> --></label></div><div class=\"parameters\"><label class=\"btn-process checkbox jsAutoItem pagelink\" data-action=\"autorefresh\"><input type=\"checkbox\" class=\"text-input jsAutoRefresh\" data-parent=\"{$CLASSPARENT_FIELDS}\" name=\"autorefresh\" {$AUTOREFRESH_FIELD}> Autorefresh</label><label class=\"btn-process jsRefreshPage pagelink\" data-action=\"refreshpage\"><span class=\"navlink-icon\"><i class=\"bx bx-refresh\"></i></span></label></div></div>\n"
+ "<div class=\"pagination\" data-source=\"jsonfields\"><!-- Top bar content goes here --><div class=\"control\"><label class=\"btn-process jsNewItem\" data-html=\"NewItem\" data-action=\"createitem\"><span class=\"navlink-icon\"><i class=\"bx bx-list-plus\"></i></span></label><label class=\"btn-process jsPageItem active pagelink\" data-html=\"PageItem\" data-index=\"1\" data-action=\"navipage\"><span class=\"navlink-text \">1</span><!-- <span class=\"\"></span> --><!-- <input type=\"hidden\" class=\"text-input \" data-parent=\"\" name=\"\" data-suffix=\"\" value=\"\"> --></label><label class=\"btn-process jsPageItem false pagelink\" data-html=\"PageItem\" data-index=\"2\" data-action=\"navipage\"><span class=\"navlink-text \">2</span><!-- <span class=\"\"></span> --><!-- <input type=\"hidden\" class=\"text-input \" data-parent=\"\" name=\"\" data-suffix=\"\" value=\"\"> --></label></div><div class=\"parameters\"><label class=\"btn-process checkbox jsAutoItem pagelink\" data-action=\"autorefresh\"><input type=\"checkbox\" class=\"text-input jsAutoRefresh\" data-parent=\"{$CLASSPARENT_FIELDS}\" name=\"autorefresh\" {$AUTOREFRESH_FIELD}> Autorefresh</label><label class=\"btn-process jsRefreshPage pagelink\" data-action=\"refreshpage\"><span class=\"navlink-icon\"><i class=\"bx bx-refresh\"></i></span></label></div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}