re = /(.+)(\?)(.+)/mi
str = 'http://www.requestly.in/replace-rule-documentation.html?type=documentation&content=html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end