$re = '/(.+)(\?)(.+)/mi';
$str = 'http://www.requestly.in/replace-rule-documentation.html?type=documentation&content=html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);