re = /[0-9]{4}[A-Z]{4}[0-9]{3}F[0-9]{4}/
str = '0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N 0136GQFR030F0000209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N
0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N
0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N '
# Print the match result
str.match(re) do |match|
puts match.to_s
end