const regex = /[0-9]{4}[A-Z]{4}[0-9]{3}F[0-9]{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{4}[A-Z]{4}[0-9]{3}F[0-9]{4}', '')
const str = `0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N 0136GQFR030F0000209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N
0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N
0209GQQH003F0011SBB FRQ05SUPERB1G 0TR 201509240410 201509240410DEN XDBKR AG99999992EF3B9 F8BB947FECMPTSGGWS G015006 IYYYNEWET 41GBLONN3N5 NY 2PYN 1G 002N YNNNPN0118GQPF000F000100NNNNYNNN0TR 9999999N N `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}