$re = '/(.*\..).(.\d++)\):(\s+error.*)/';
$str = '..\\main.c(81): error: #20: identifier "s" is undefined';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);