const regex = /(.*\..).(.\d++)\):(\s+error.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\..).(.\\d++)\\):(\\s+error.*)', '')
const str = `..\\main.c(81): error: #20: identifier "s" is undefined`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}