// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^/(?<page>quizzes)(?:/(?<subpage>[\w-]+)?)?(?:\.xml)$").unwrap();
let string = "# EXPECTED URL MATCHES
/quizzes
/quizzes/
/quizzes/food
/quizzes/food/
/quizzes.xml
/quizzes/food.xml
# EXPECTED URL NON-MATCHES
/quizzes2
/quizzes.xml/
/quizzes/food.xml/
/investigations
/investigations/foo
/jobs/something
/foo/bar
/jp/index
/about
/press
/uk/shopping
/esp/shopping
/shopping
/jp/shopping
/jp/quizzes
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}