$re = '~^/(?<page>quizzes)(?:/(?<subpage>[\w-]+)?)?(?:\.xml)$~m';
$str = '# EXPECTED URL MATCHES
/quizzes
/quizzes/
/quizzes/food
/quizzes/food/
/quizzes.xml
/quizzes/food.xml
# EXPECTED URL NON-MATCHES
/quizzes2
/quizzes.xml/
/quizzes/food.xml/
/investigations
/investigations/foo
/jobs/something
/foo/bar
/jp/index
/about
/press
/uk/shopping
/esp/shopping
/shopping
/jp/shopping
/jp/quizzes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);