// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*\ \(Transaction\ ID\ ([0-9]*)\)[a-zA-Z0-9\.\|\ \/\:\(\)\<\>\=\-\#\"\,]*"#).unwrap();
let string = "Transformers: The IDW Collection, Vol. 5 (#82973) stock reduced from 18 to 17.|Order status changed from Failed to Processing.|Authorize.Net CIM Charge Approved: Visa ending in 5991 (expires 06/21) (Transaction ID 60782052346)|Authorize.Net CIM Payment Failed (Status code 2: Error Code: 27 - The transaction has been declined because of an AVS mismatch. The address provided does not match billing address of cardholder. Transaction ID 60782050745) Order status changed from Pending payment to Failed.";
let substitution = "WINNER";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}